The issue affecting Secure Viewer has been resolved, and full functionality has been restored.
Posted May 04, 2026 - 07:01 UTC
Monitoring
The issue affecting Secure Viewer has been resolved, and the service is now operating normally. We are continuing to monitor to ensure stability.
Posted May 04, 2026 - 06:58 UTC
Update
The issue affecting Secure Viewer has not yet been resolved. Our team is actively working on implementing a fix and will provide updates as progress is made.
Posted May 04, 2026 - 06:50 UTC
Update
The issue affecting Secure Viewer has been identified, and our team is actively working on a fix.
We will share further updates as progress is made. Thank you for your patience.
Posted May 04, 2026 - 06:29 UTC
Update
We are continuing to investigate the issue affecting Secure Viewer. Our team remains actively engaged and working toward a resolution.
We will provide further updates as soon as more information is available. Thank you for your continued patience.
Posted May 04, 2026 - 06:21 UTC
Investigating
We have identified the issue affecting Secure Viewer where users may see the error: “Connection is lost — you can still view the document.”
Our team is actively investigating the root cause and working toward a resolution. We will continue to provide updates as more information becomes available.
Posted May 04, 2026 - 05:59 UTC
This incident affected: 🇺🇸 US Region (US - Data Services), 🇪🇺 EU Region (EU - Data Services), 🇬🇧 UK Region (UK - Data Services), 🇨🇦 Canada Region (Canada - Data Services), 🇦🇺 AU Region (AU - Data Services), and 🇨🇳 CN Region (CN - Data Services).